C Series IP PhonesProduct Brochure
C63G/C63GP
Entry-level for SMEs
Product Details

Product Overview
The Dinstar C63GP is an entry-level, multi-functional HD IP phone designed for ease of use and exceptional value. Ideal for diverse environments, it delivers superior HD voice quality and a rich set of telephony features to meet the needs of small and medium-sized businesses, call centers, and industry-specific users.
The C63GP IP phone features a 320x240 resolution color backlit LCD, supports Gigabit Ethernet, accommodates 6 SIP accounts, and enables 5-way conferencing. When paired with an IPPBX, it delivers rich business capabilities.
Other models in the same series
Key Features
- 6 SIP accounts
- Maximum 5 remote phonebook URLs supported
- SIP v1 (RFC2543), v2 (RFC3261)
Technical Features
- 6 SIP accounts
- Upgrade software via web
- Network packet capture
- TR069
- DNS SRV/A Query/NAT-PMP Query
- Maximum 5 remote phonebook URLs supported
- SIP TLS, SRTP encryption
- SIP v1 (RFC2543), v2 (RFC3261)
- Five-party meeting
- Busy Transfer / Consultation Transfer
- Speed Dial, Hotline
- Call Forwarding
- Call Waiting
- Answer by proxy, Group answer by proxy
Technical Specifications (3Item
- DTMF Mode
- In-Band, RFC2833, and SIP INFO
- Phonebook
- 1000 groups
- Narrowband Voice Coding
- PCMA, PCMU, G.729, G.723_53, G.723_63, G.726_32